查看: 3040|回复: 28

[其他] 【重要】地图SDK v3.3.1已修复 Xcode8.3 Warning的问题

[复制链接]
liyanan624 发表于 2017-4-10 12:20:20 | 显示全部楼层 |阅读模式
iOS地图sdk
版本号: v3.3.1
手机型号: all
使用的接口/api:
效果截图: -
调用代码/参数:
使用的AK: 您无权查看此信息!
本帖最后由 liyanan624 于 2017-5-10 12:06 编辑

亲爱的开发者,

5月10日iOS v3.3.1,已修复使用Xcode 8.3 产生的warning问题。

同时将swift Demo:swift语言升级为 swift v3.1。

感谢大家的反馈 [鞠躬] 。



百度地图SDK团队


camel_2013 发表于 2017-5-10 18:10:04 | 显示全部楼层
导航sdk的这种warning什么时候修复????
回复 支持 1 反对 0

使用道具 举报

三世客栈 发表于 2017-4-18 11:08:19 | 显示全部楼层
xcode8.3 集成百度地图运行就crash也是这个问题吗
 楼主| liyanan624 发表于 2017-4-18 15:02:03 | 显示全部楼层
三世客栈 发表于 2017-4-18 11:08
xcode8.3 集成百度地图运行就crash也是这个问题吗

运行 crash 是否有log? 需要分析一下
三世客栈 发表于 2017-4-18 15:29:04 | 显示全部楼层
找到问题了 是Bundle identifier 问题 我原来是$(PRODUCT_BUNDLE_IDENTIFIER) 这个自动读取 就一直崩溃 现在变成这个com.yilai.${PRODUCT_NAME:rfc1034identifier} 就不蹦了 但是一直是授权失败 还在找为什么
三世客栈 发表于 2017-4-18 15:32:52 | 显示全部楼层
liyanan624 发表于 2017-4-18 15:02
运行 crash 是否有log? 需要分析一下

不知道这个问题能不能帮我解答下
 楼主| liyanan624 发表于 2017-4-18 16:38:18 | 显示全部楼层
三世客栈 发表于 2017-4-18 15:32
不知道这个问题能不能帮我解答下

这个我们查一下问题
三世客栈 发表于 2017-4-18 16:51:11 | 显示全部楼层
嗯 一直是230 授权失败 我不知道该怎么解决了啊
三世客栈 发表于 2017-4-18 16:55:10 | 显示全部楼层
liyanan624 发表于 2017-4-18 16:38
这个我们查一下问题

改成自动获取就能授权成功 但是一直崩溃
 楼主| liyanan624 发表于 2017-4-19 15:41:16 | 显示全部楼层
三世客栈 发表于 2017-4-18 16:55
改成自动获取就能授权成功 但是一直崩溃

bundle identifier 创建项目时候自动生成的 ,您这个应该是哪里没设置好。

我们工程师用 的8.3.1, 没有crash 。也可以给我一个Demo,我们在继续看一下。
李丹bhjj 发表于 2017-5-10 12:52:07 | 显示全部楼层
本帖最后由 李丹bhjj 于 2017-5-10 12:57 编辑

首先感谢一下,但是

CocoaPods trunk 没更新, 也没有tag。

-------------------------------
两分钟后看了下,有tag了。
我的靑春谁的城 发表于 2017-5-10 13:51:27 | 显示全部楼层
bundle文件为什么下载的没有
温渴欣 发表于 2017-5-10 15:33:50 | 显示全部楼层
依旧还有三十个警告 xcode 版本是8.3.2
Screen Shot 2017-05-10 at 3.30.35 PM.png
 楼主| liyanan624 发表于 2017-5-10 21:26:44 | 显示全部楼层
本帖最后由 liyanan624 于 2017-5-10 21:28 编辑
三世客栈 发表于 2017-4-18 11:08
xcode8.3 集成百度地图运行就crash也是这个问题吗

您说的是与环信一起用 crash吗?这个是因为环信将第三方openssl静态库打入了sdk,导致的吧? 与 xcode8.3  没有关系
我们之前了解到的情况是 xcode 8.3 不会导致 crash,是有warning。


 楼主| liyanan624 发表于 2017-5-10 21:28:38 | 显示全部楼层
温渴欣 发表于 2017-5-10 15:33
依旧还有三十个警告 xcode 版本是8.3.2

谢谢反馈,我们再看看
师航free 发表于 2017-5-11 10:26:50 | 显示全部楼层
导航sdK  也会有这种⚠️
 楼主| liyanan624 发表于 2017-5-11 14:16:53 | 显示全部楼层
师航free 发表于 2017-5-11 10:26
导航sdK  也会有这种⚠️

已内部 转达导航SDK的RD同学
Like_冬季 发表于 2017-5-12 10:09:26 | 显示全部楼层
你们为甚么要把配置文件放Documents文件夹啊!!我们的app要加一个能让用户访问共享文件夹的功能,而苹果指定唯一的共享文件夹就是Documents文件夹!我们被拒绝的原因就是这个文件夹里有不允许用户分享的文件!搞得我们都无法加新功能了!
345进 发表于 2017-5-12 16:08:12 | 显示全部楼层
本帖最后由 345进 于 2017-5-12 16:09 编辑


师航free 发表于 2017-5-16 15:54:27 | 显示全部楼层
liyanan624 发表于 2017-5-11 14:16
已内部 转达导航SDK的RD同学

woshiwxyone 发表于 2017-5-22 14:20:47 | 显示全部楼层
楼上你好,我这边也是在Xcode8.3.2上iOS7真机上,一运行就闪退,百度地图版本v_3.2.1

点评

swift 最低支持iOS 8.0及以上系统。 您的现象应该是 想运行到iOS7.0的系统,都load不出来吧  发表于 2017-5-25 16:18
水瓶wendyW 发表于 2017-5-22 18:07:33 | 显示全部楼层
使用V3.3.1 的sdk,会报v3.2.1的错,报了N多个。  上个版本用的是v3.1.1.。请问这是为什么,怎么解决?  


file:///Users/user/Desktop/ElevatorMaintenance/ElevatorMaintenance/Framework/Third/BaiduMap_IOSSDK_v3.2.1_Lib/BaiduMapAPI_Map.framework/Resources/mapapi.bundle/images/icon_action_paopao_middle_right_highlighted.png: warning: Missing file: /Users/user/Desktop/ElevatorMaintenance/ElevatorMaintenance/Framework/Third/BaiduMap_IOSSDK_v3.2.1_Lib/BaiduMapAPI_Map.framework/Resources/mapapi.bundle/images/icon_action_paopao_middle_right_highlighted.png is missing from working copy
woshiwxyone 发表于 2017-5-23 16:08:00 | 显示全部楼层
楼主,回复我一下,为什么使用Xcode8.3.2,运行SDK中的swiftdemo,在iOS7.0.4上一运行就闪退呢?

点评

swift 最低支持iOS 8.0及以上系统。 您的现象应该是 想运行到iOS7.0的系统,都load不出来吧  发表于 2017-5-25 16:19
 楼主| liyanan624 发表于 2017-5-25 16:18:02 | 显示全部楼层
本帖最后由 liyanan624 于 2017-5-25 16:28 编辑
woshiwxyone 发表于 2017-5-23 16:08
楼主,回复我一下,为什么使用Xcode8.3.2,运行SDK中的swiftdemo,在iOS7.0.4上一运行就闪退呢? ...

swift 3.x 最低支持iOS 8.0及以上系统。

您的现象应该是 想运行到iOS7.0的系统,都load不出来吧
 楼主| liyanan624 发表于 2017-5-25 16:18:32 | 显示全部楼层
本帖最后由 liyanan624 于 2017-5-25 16:28 编辑
woshiwxyone 发表于 2017-5-22 14:20
楼上你好,我这边也是在Xcode8.3.2上iOS7真机上,一运行就闪退,百度地图版本v_3.2.1
...

swift 3.x 最低支持iOS 8.0及以上系统。
您的现象应该是 想运行到iOS7.0的系统,都load不出来吧
woshiwxyone 发表于 2017-5-26 09:10:38 | 显示全部楼层
woshiwxyone 发表于 2017-5-22 14:20
楼上你好,我这边也是在Xcode8.3.2上iOS7真机上,一运行就闪退,百度地图版本v_3.2.1
...

但是我在iOS7.1上面又能正常运行,不会闪退
woshiwxyone 发表于 2017-5-26 09:11:49 | 显示全部楼层
woshiwxyone 发表于 2017-5-23 16:08
楼主,回复我一下,为什么使用Xcode8.3.2,运行SDK中的swiftdemo,在iOS7.0.4上一运行就闪退呢? ...

还没到load,一运行就闪退,报dyld: Symbol not found: _kCLErrorUserInfoAlternateRegionKey
  Referenced from: /private/var/mobile/Applications/BB1E183C-8DCE-4025-B719-DFEF110FDD81/chengdu.app/Frameworks/libswiftCoreLocation.dylib
  Expected in: /System/Library/Frameworks/CoreLocation.framework/CoreLocation
in /private/var/mobile/Applications/BB1E183C-8DCE-4025-B719-DFEF110FDD81/chengdu.app/Frameworks/libswiftCoreLocation.dylib

小黑屋|手机版|百度地图开放平台 ( 京ICP证030173号 )

GMT+8, 2017-6-29 11:44 , Processed in 0.305147 second(s), 27 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表