查看: 237|回复: 10

[咨询求助] 关于算路失败的问题

[复制链接]
南工大310 发表于 2017-6-1 22:31:09 | 显示全部楼层 |阅读模式
本帖最后由 南工大310 于 2017-6-1 22:59 编辑

2017-06-01 22:58:37.537725 mapDemo2[1702:581734] [DYMTLInitPlatform] platform initialization successful
2017-06-01 22:58:38.479619 mapDemo2[1702:581624] Metal GPU Frame Capture Enabled
2017-06-01 22:58:38.479989 mapDemo2[1702:581624] Metal API Validation Enabled
2017-06-01 22:58:39.164 E|BDSTTSEngine.mm:633 verify license failed: -2
2017-06-01 22:58:39.447 E|BDSTTSEngine.mm:764 get license failed: -101
2017-06-01 22:58:39.448 E|BDSTTSEngine.mm:637 failed to get license from server
2017-06-01 22:58:39.449 E|BDSEmbeddedSynthesizerImpl.m:197 start tts engine failed
2017-06-01 22:58:47.325 E|BDSTTSEngine.mm:633 verify license failed: -2
2017-06-01 22:58:47.405 E|BDSTTSEngine.mm:764 get license failed: -101
2017-06-01 22:58:47.406 E|BDSTTSEngine.mm:637 failed to get license from server
2017-06-01 22:58:47.407 E|BDSEmbeddedSynthesizerImpl.m:197 start tts engine failed
2017-06-01 22:58:51.995983 mapDemo2[1702:581624] 算路失败

打印上面的结果,请问我哪里出错了。。。
admin 发表于 2017-6-2 10:10:46 | 显示全部楼层
你好,从日志里看不出原因,可以断点看下错误码是多少?
 楼主| 南工大310 发表于 2017-6-2 14:53:04 | 显示全部楼层
admin 发表于 2017-6-2 10:10
你好,从日志里看不出原因,可以断点看下错误码是多少?

你好,我是拷贝demo的,之前用cocopads导入了百度地图sdk,后来手动导入百度地图sdk,两种方式的情况下,都不能和这个版本的百度导航sdk共存,一直显示失败,用pod把百度地图sdk清掉就可以使用导航sdk了,请问我是要下载导入低版本的导航sdk吗?
 楼主| 南工大310 发表于 2017-6-2 15:57:20 | 显示全部楼层
admin 发表于 2017-6-2 10:10
你好,从日志里看不出原因,可以断点看下错误码是多少?

请问我现在该怎么办哦
小K2114 发表于 2017-6-2 18:12:00 | 显示全部楼层
你是不是使用了 最新的地图3.3.2版本的地图SDK  貌似同时使用地图和导航的话 会出现这个问题
 楼主| 南工大310 发表于 2017-6-2 19:57:36 | 显示全部楼层
小K2114 发表于 2017-6-2 18:12
你是不是使用了 最新的地图3.3.2版本的地图SDK  貌似同时使用地图和导航的话 会出现这个问题 ...

是的,我用的就是最新的百度地图sdk
wwwezcxnet 发表于 2017-6-3 10:20:10 | 显示全部楼层
你好,我也遇到同样的问题,//算路失败回调  到  算路失败,用到百度SDK3.3.2,导航是3.1.0,怎么解决,告诉我一下,谢谢!
angel_inworld 发表于 2017-6-5 12:56:59 | 显示全部楼层
wwwezcxnet 发表于 2017-6-3 10:20
你好,我也遇到同样的问题,//算路失败回调  到  算路失败,用到百度SDK3.3.2,导航是3.1.0,怎么解决,告诉 ...

兄弟们你们解决了吗?
admin 发表于 2017-6-9 10:23:13 | 显示全部楼层
angel_inworld 发表于 2017-6-5 12:56
兄弟们你们解决了吗?

最新版本的地图sdk和3.1.0版本的导航sdk同时使用会有问题。
可以把新版导航SDK配合地图的v 3.2.1版本一起使用。
爱删除00 发表于 2017-6-19 20:17:49 | 显示全部楼层
admin 发表于 2017-6-9 10:23
最新版本的地图sdk和3.1.0版本的导航sdk同时使用会有问题。
可以把新版导航SDK配合地图的v 3.2.1版本一起 ...

使用的是最新版本的导航SDK  地图是V3.2.1 还是报错 verify license failed: -2 get license failed: -101  failed to get license from server
爱删除00 发表于 5 天前 | 显示全部楼层
Error Domain=domainRoutePlanError Code=412000300 "(null)" UserInfo={routeplan_error_code=412000300}
这个是算路失败的返回状态码

小黑屋|手机版|百度地图开放平台 ( 京ICP证030173号 )

GMT+8, 2017-6-29 11:37 , Processed in 0.195798 second(s), 19 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表